Welcome to our support center

How can we help you?

Which Operating System (OS) version does iMobile support?

iMobile is compatible with any handset having

  • Android OS version 2.1 and above
  • iOS 8.0 and higher versions
  • Windows 8 and above
  • CDMA device users cannot avail iMobile services